Rival Insurance Technology status page
Incidents

Peacehills is down

resolvedMAJORaffectedrival-insurancelasted 13min 59s

The incident has been resolved

resolved
Apr 28 00:32:50 (UTC)

Peacehills - prod we've identified an issue and are Investigating.

investigating
Apr 28 00:18:50 (UTC)
Powered by Checkly