Incidents

Economical is down

MAJORaffected
rival-insurance
lasted 14min

RESOLVED

lasted 14min

The incident has been resolved

INVESTIGATING

14min earlier

Economical - prod we've identified an issue and are Investigating.