Rival Insurance Technology status page
Incidents

RPM is down

MAJORaffectedrival-insurancelasted1min 53s

The incident has been resolved

resolved
Mar 9 00:59:51 (UTC)

RPM - prod we've identified an issue and are Investigating.

investigating
Mar 9 00:57:58 (UTC)
Powered by Checkly